XMLDocument.load()

document.load() fait partie d'une ancienne version du module W3C DOM Level 3 Load & Save. Elle peut être utilisée avec document.async pour indiquer si la requête est synchrone ou asynchrone (par défaut). À partir d'au moins Gecko 1.9, elle ne prend plus en charge le chargement inter-site de documents (utilisez XMLHttpRequest à la place).

Exemples

var docXml = document.implementation.createDocument("", "test", null);

function documentCharge (e) {
  alert(new XMLSerializer().serializeToString(e.target)); // Donne le contenu de querydata.xml comme une chaîne
}

xmlDoc.addEventListener("load", documentCharge, false);
xmlDoc.load('querydata.xml');

Voir aussi l'extrait de chargement dans le dossier de tests XML. (Pour tester cette fonctionnalité, créez les fichiers sur votre disque local ou sur un serveur web, plutôt que de charger le fichier load.html depuis la page générée par LXR, qui servira le fichier text.xml comme HTML.)

Spécification

Compatibilité des navigateurs

Update compatibility data on GitHub
OrdinateurMobile
ChromeEdgeFirefoxInternet ExplorerOperaSafariWebview AndroidChrome pour AndroidFirefox pour AndroidOpera pour AndroidSafari sur iOSSamsung Internet
load
ObsolèteNon-standard
Chrome Aucun support NonEdge Aucun support NonFirefox Aucun support 3 — 68
Notes
Aucun support 3 — 68
Notes
Notes See bug 332175 for removal.
Aucun support 1 — 3
Notes
Notes Before version 3, Firefox supported cross-origin loads, even in cases where this would violate CORS.
IE Aucun support NonOpera Aucun support NonSafari Aucun support NonWebView Android Aucun support NonChrome Android Aucun support NonFirefox Android Aucun support 4 — 68
Notes
Aucun support 4 — 68
Notes
Notes See bug 332175 for removal.
Opera Android Aucun support NonSafari iOS Aucun support NonSamsung Internet Android Aucun support Non

Légende

Aucun support  
Aucun support
Fonctionnalité non-standard. Celle-ci peut être incorrectement supportée par les autres navigateurs.
Fonctionnalité non-standard. Celle-ci peut être incorrectement supportée par les autres navigateurs.
Obsolète. Les nouveaux sites web ne doivent pas utiliser cette fonctionnalité.
Obsolète. Les nouveaux sites web ne doivent pas utiliser cette fonctionnalité.
Voir les notes d'implémentation.
Voir les notes d'implémentation.

Voir aussi